summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2012-06-24 19:34:08 +0300
committerAndrei Karas <akaras@inbox.ru>2012-06-24 21:41:20 +0300
commit3b537e109df901df3da4c706f827c8d3d39a7238 (patch)
treeae5a83f71954aaeb45ce3f8d609e6f4a8dc0678c /configure.ac
parent4ef35e9ef757da1db724c5d784048601144c934c (diff)
downloadplus-3b537e109df901df3da4c706f827c8d3d39a7238.tar.gz
plus-3b537e109df901df3da4c706f827c8d3d39a7238.tar.bz2
plus-3b537e109df901df3da4c706f827c8d3d39a7238.tar.xz
plus-3b537e109df901df3da4c706f827c8d3d39a7238.zip
Add basic support for eathena stable.
Can register, create char, connect to map server and get map info.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a68562cbb..eb2c55fc8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -178,7 +178,7 @@ fi
# Enable manaserv
AC_ARG_ENABLE(manaserv,
-[ --enable-manaserv Turn on manaserv],
+[ --enable-manaserv Turn on manaserv support],
[case "${enableval}" in
yes) with_manaserv=true ;;
no) with_manaserv=false ;;
@@ -187,6 +187,17 @@ esac],[with_manaserv=false])
AM_CONDITIONAL(ENABLE_MANASERV, test x$with_manaserv = xtrue)
+# Enable eAthena
+AC_ARG_ENABLE(eathena,
+[ --enable-eathena Turn on eAthena support],
+[case "${enableval}" in
+ yes) with_eathena=true ;;
+ no) with_eathena=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-eathena) ;;
+esac],[with_eathena=false])
+
+AM_CONDITIONAL(ENABLE_EATHENA, test x$with_eathena = xtrue)
+
# Enable portable
AC_ARG_ENABLE(portable,
[ --enable-portable Turn on portable mode for linux],