summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-01-30 15:56:42 +0300
committerAndrei Karas <akaras@inbox.ru>2017-01-30 15:56:42 +0300
commit1e42f9a4691b074eac5b47536f9f828809fe16ca (patch)
treeef98365fa5a44232ba56528cb7a62d33925be8c4 /configure.ac
parent4d3cbb385fcfb79bd559c745ca528beef7f41344 (diff)
downloadplus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.gz
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.bz2
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.xz
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.zip
Add configure flag for prevent bulding main game code.
New configure flag:--with-manaplusgame / --without-manaplusgame By default it allow build main game code.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59ff88913..080bdf791 100755
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,15 @@ fi
AM_CONDITIONAL(ENABLE_DYECMD, test x$with_dyecmd = xyes)
+# Option to enable ManaPlus game
+AC_ARG_WITH(manaplusgame,[ --without-manaplusgame don't build ManaPlus game ] )
+if test "x$with_manaplusgame" == "xno"; then
+ with_manaplusgame=no
+else
+ with_manaplusgame=yes
+fi
+AM_CONDITIONAL(ENABLE_MANAPLUSGAME, test x$with_manaplusgame = xyes)
+
# Enable nacl build
AC_ARG_ENABLE(naclbuild,
[ --enable-naclbuild Turn on nacl building],