summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-01-10 22:14:21 +0300
committerAndrei Karas <akaras@inbox.ru>2017-01-10 22:14:21 +0300
commit0dcedd986aa0eb8129df2b934a5fc4ebe35041d8 (patch)
tree2f0fa52803da73a50ae2bdc9a58ef613b3cafc4d /configure.ac
parent571cf00b4aac82777c7c1efc3e8ac6d5bc459c9c (diff)
downloadplus-0dcedd986aa0eb8129df2b934a5fc4ebe35041d8.tar.gz
plus-0dcedd986aa0eb8129df2b934a5fc4ebe35041d8.tar.bz2
plus-0dcedd986aa0eb8129df2b934a5fc4ebe35041d8.tar.xz
plus-0dcedd986aa0eb8129df2b934a5fc4ebe35041d8.zip
Add configure flag with_gcov for create coverage data.
Disabled by default.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fe9ad6f2..c64befcac 100755
--- a/configure.ac
+++ b/configure.ac
@@ -314,6 +314,17 @@ AC_ARG_ENABLE(applebuild,
esac],[applebuild_enabled=false])
+# Option to enable gcov
+AC_ARG_WITH(gcov,[ --with-gcov use gcov ] )
+if test "x$with_gcov" == "xyes"; then
+ with_gcov=yes
+ CPPFLAGS="$CPPFLAGS -coverage"
+ LDFLAGS="$LDFLAGS -coverage"
+else
+ with_gcov=no
+fi
+AM_CONDITIONAL(USE_GCOV, test x$with_gcov = xyes)
+
# Option to enable OpenGL
AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
if test "x$with_opengl" == "xno"; then