summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-03-08 23:00:29 +0300
committerAndrei Karas <akaras@inbox.ru>2017-03-08 23:03:29 +0300
commit0b26c83fd6c485b6686244a41647324fcf1a1843 (patch)
treed8fe2e447d46287cc0d9e71cc96d5c677ae1eddb /configure.ac
parent308ce845d53c6544f9577982eef26cd252ec2f79 (diff)
downloadplus-0b26c83fd6c485b6686244a41647324fcf1a1843.tar.gz
plus-0b26c83fd6c485b6686244a41647324fcf1a1843.tar.bz2
plus-0b26c83fd6c485b6686244a41647324fcf1a1843.tar.xz
plus-0b26c83fd6c485b6686244a41647324fcf1a1843.zip
Enable stack generation if target platform support this.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ee915424..f68adfb59 100755
--- a/configure.ac
+++ b/configure.ac
@@ -638,6 +638,22 @@ fi
AC_CHECK_LD_FLAG(-rdynamic, have_rdynamic)
AM_CONDITIONAL(HAVE_RDYNAMIC, test x$have_rdynamic = xyes)
+AC_CHECK_HEADERS([execinfo.h],
+ [
+ AC_SEARCH_LIBS([backtrace],
+ [execinfo],
+ [
+ have_execinfo=yes
+ ],
+ [
+ have_execinfo=no
+ ]
+ )
+ ],
+ []
+)
+AM_CONDITIONAL(HAVE_EXECINFO, test x$have_execinfo = xyes)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile