summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Sagunov <danilka.pro@gmail.com>2012-10-15 17:32:01 +0400
committerDan Sagunov <danilka.pro@gmail.com>2012-10-15 17:32:01 +0400
commit09fef0e15b20d0c987c301787d4cc5377d1cc649 (patch)
treee6be88db87e6731ee3d11c631fd2db5750d45c7a /configure.ac
parentb2b348d4baf2891fd82635e068a4f64d2694ba6d (diff)
downloadplus-09fef0e15b20d0c987c301787d4cc5377d1cc649.tar.gz
plus-09fef0e15b20d0c987c301787d4cc5377d1cc649.tar.bz2
plus-09fef0e15b20d0c987c301787d4cc5377d1cc649.tar.xz
plus-09fef0e15b20d0c987c301787d4cc5377d1cc649.zip
Added --without-pthread flag.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 256f17507..46d88b797 100755
--- a/configure.ac
+++ b/configure.ac
@@ -30,8 +30,14 @@ AC_PATH_PROG(PKG_CONFIG, pkg-config)
AC_PATH_PROG(CURL_CONFIG, curl-config)
# Checks for libraries
-AC_CHECK_LIB([pthread], [pthread_create], ,
-AC_MSG_ERROR([ *** Unable to find pthread library]))
+AC_ARG_WITH(pthread,[ --without-pthread don't check for pthread ] )
+if test "x$with_pthread" == "xno"; then
+ without_pthread=yes
+else
+ AC_CHECK_LIB([pthread], [pthread_create], ,
+ AC_MSG_ERROR([ *** Unable to find pthread library]))
+ withoud_pthread=no
+fi
if test -n "$SDL_CONFIG"; then