summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2018-05-22 19:18:19 +0300
committerAndrei Karas <akaras@inbox.ru>2018-05-22 19:18:19 +0300
commit069ef2445ddf4f8ab1392f8e559ef258b315e92d (patch)
tree0d9e19f68ff7b0cc721ed1addc080c9d10e11530 /configure.ac
parent172afd4cd9e7284741904424f5e567564a218210 (diff)
downloadplus-069ef2445ddf4f8ab1392f8e559ef258b315e92d.tar.gz
plus-069ef2445ddf4f8ab1392f8e559ef258b315e92d.tar.bz2
plus-069ef2445ddf4f8ab1392f8e559ef258b315e92d.tar.xz
plus-069ef2445ddf4f8ab1392f8e559ef258b315e92d.zip
Add configure option for enable/disable accepting password from command line.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ab75e9bb..48e44a868 100755
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,19 @@ esac],[openglerrors_enabled=false])
AM_CONDITIONAL(ENABLE_OPENGLERRORS, test x$openglerrors_enabled = xtrue)
+# Enable password from command line
+AC_ARG_ENABLE(commandlinepassword,
+[ --enable-commandlinepassword Enable command line option for set password],
+[case "${enableval}" in
+ yes) commandlinepassword_enabled=true
+ ;;
+ no) commandlinepassword_enabled=false
+ ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-commandlinepassword) ;;
+esac],[commandlinepassword_enabled=false])
+
+AM_CONDITIONAL(ENABLE_COMMANDLINEPASSWORD, test x$commandlinepassword_enabled = xtrue)
+
# Checks for android.
AC_ARG_ENABLE(androidbuild,
[ --enable-androidbuild Turn on android building],