summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2013-11-01 00:09:32 +0300
committerAndrei Karas <akaras@inbox.ru>2013-11-01 00:09:32 +0300
commit029818ba44703c5151f8d916284e307b05d08fa9 (patch)
tree785726402146454e69acf1b18ad12f6890e29932 /configure.ac
parent1936a2bcfad1b37385aec3d84efabf2570a8c9e8 (diff)
downloadplus-029818ba44703c5151f8d916284e307b05d08fa9.tar.gz
plus-029818ba44703c5151f8d916284e307b05d08fa9.tar.bz2
plus-029818ba44703c5151f8d916284e307b05d08fa9.tar.xz
plus-029818ba44703c5151f8d916284e307b05d08fa9.zip
Add configure option --enable-checks for check some calls (disabled by default)
Also add configuration listeners removing in objects.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73e6e97b3..367fa66cc 100755
--- a/configure.ac
+++ b/configure.ac
@@ -312,6 +312,17 @@ esac],[with_eathena=false])
AM_CONDITIONAL(ENABLE_EATHENA, test x$with_eathena = xtrue)
+# Enable checks
+AC_ARG_ENABLE(checks,
+[ --enable-checks Turn on internal checks (can be slow)],
+[case "${enableval}" in
+ yes) with_checks=true ;;
+ no) with_checks=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-checks) ;;
+esac],[with_checks=false])
+
+AM_CONDITIONAL(ENABLE_CHECKS, test x$with_checks = xtrue)
+
# Enable portable
AC_ARG_ENABLE(portable,
[ --enable-portable Turn on portable mode for linux],