summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Irwin <antumdeluge@gmail.com>2022-07-14 16:43:11 -0700
committerjak1 <jak1@themanaworld.org>2022-12-18 17:24:32 +0000
commit0400eac96a69a322fd6d77868eb7edad81cc860f (patch)
tree92910694e8d975fb0a57f32093da32028b5b50fc /CMakeLists.txt
parente48e1826ec18d050db78b9c542501f5a92057006 (diff)
downloadplus-0400eac96a69a322fd6d77868eb7edad81cc860f.tar.gz
plus-0400eac96a69a322fd6d77868eb7edad81cc860f.tar.bz2
plus-0400eac96a69a322fd6d77868eb7edad81cc860f.tar.xz
plus-0400eac96a69a322fd6d77868eb7edad81cc860f.zip
Add CMake SDL2 build support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6224f9d5f..2231aaaab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMake/Modules)
FIND_PACKAGE(Gettext)
OPTION(WITH_OPENGL "Enable OpenGL support" ON)
+OPTION(USE_SDL2 "Build with SDL 2.0 instead of 1.2" OFF)
OPTION(ENABLE_NLS "Enable building of tranlations" ON)
OPTION(ENABLE_TMWA "Enable tmwA support" ON)