summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..4367755
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,20 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+bin_PROGRAMS = mplint
+
+mplint_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
+ -DLOCALEDIR=\""$(localedir)"\" \
+ -Wall -Wextra
+
+mplint_SOURCES = \
+ lintmanager.cpp \
+ lintmanager.h \
+ localconsts.h \
+ main.cpp \
+ rulebase.cpp \
+ rulebase.h \
+ rules/dump.cpp \
+ rules/dump.h
+
+# set the include path found by configure
+AM_CPPFLAGS = $(all_includes)