summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-05-13 13:39:52 +0200
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-05-16 23:25:19 +0200
commite5c7ef4573adcdcafec7523a77724b171456b215 (patch)
tree797833ddc766d92131da86096de81741a94f4d20 /src/Makefile.am
parent0a48f0d41653d0a0758fc84fd6a18830bd37da18 (diff)
downloadmanaserv-e5c7ef4573adcdcafec7523a77724b171456b215.tar.gz
manaserv-e5c7ef4573adcdcafec7523a77724b171456b215.tar.bz2
manaserv-e5c7ef4573adcdcafec7523a77724b171456b215.tar.xz
manaserv-e5c7ef4573adcdcafec7523a77724b171456b215.zip
Changed and split up the default location for loading data
Instead of loading data from a 'data' directory in the current working directory, the server now uses clientDataPath and serverDataPath as specified in the configuration. This removes the need to set up symbolic links in order to merge these two types of data. The default values point to example/clientdata and example/serverdata, where a minimal example world can be developed to make setting up an initial server quick and easy. The XML::Document convenience class was copied over from the client. Also, the ResourceManager is now shared between both servers, since the account client is reading items.xml. Reviewed-by: Jared Adams
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e31cf2a..ff53714f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,6 +41,8 @@ manaserv_account_SOURCES = \
common/configuration.hpp \
common/configuration.cpp \
common/inventorydata.hpp \
+ common/resourcemanager.hpp \
+ common/resourcemanager.cpp \
dal/dalexcept.h \
dal/dataprovider.h \
dal/dataprovider.cpp \
@@ -68,6 +70,8 @@ manaserv_account_SOURCES = \
utils/processorutils.cpp \
utils/sha256.h \
utils/sha256.cpp \
+ utils/string.hpp \
+ utils/string.cpp \
utils/stringfilter.h \
utils/stringfilter.cpp \
utils/timer.cpp \
@@ -76,8 +80,7 @@ manaserv_account_SOURCES = \
utils/tokendispenser.hpp \
utils/tokendispenser.cpp \
utils/xml.hpp \
- utils/xml.cpp \
- utils/string.cpp
+ utils/xml.cpp
manaserv_game_CXXFLAGS = -Wall
@@ -91,6 +94,8 @@ manaserv_game_SOURCES = \
common/inventorydata.hpp \
common/permissionmanager.hpp \
common/permissionmanager.cpp \
+ common/resourcemanager.hpp \
+ common/resourcemanager.cpp \
game-server/accountconnection.hpp \
game-server/accountconnection.cpp \
game-server/actor.hpp \
@@ -134,8 +139,6 @@ manaserv_game_SOURCES = \
game-server/postman.hpp \
game-server/quest.hpp \
game-server/quest.cpp \
- game-server/resourcemanager.hpp \
- game-server/resourcemanager.cpp \
game-server/skillmanager.hpp \
game-server/skillmanager.cpp \
game-server/spawnarea.hpp \
@@ -175,6 +178,8 @@ manaserv_game_SOURCES = \
utils/logger.cpp \
utils/processorutils.hpp \
utils/processorutils.cpp \
+ utils/string.hpp \
+ utils/string.cpp \
utils/stringfilter.h \
utils/stringfilter.cpp \
utils/timer.h \
@@ -187,8 +192,7 @@ manaserv_game_SOURCES = \
utils/xml.hpp \
utils/xml.cpp \
utils/zlib.hpp \
- utils/zlib.cpp \
- utils/string.cpp
+ utils/zlib.cpp
if BUILD_MYSQL
manaserv_account_SOURCES += \