summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-30 16:20:33 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-30 16:20:33 +0000
commit25914cddf606e683a4226f46b56f800400d633d3 (patch)
tree58a95b50fc59a45459906d109b4768aa4124951d /src/Makefile.am
parent5af1c90d2f86e10de74285d89ee975bd959a6556 (diff)
downloadmanaserv-25914cddf606e683a4226f46b56f800400d633d3.tar.gz
manaserv-25914cddf606e683a4226f46b56f800400d633d3.tar.bz2
manaserv-25914cddf606e683a4226f46b56f800400d633d3.tar.xz
manaserv-25914cddf606e683a4226f46b56f800400d633d3.zip
Got rid of abstract storage and reference-counted pointers. Fixed lifetime of accounts and characters in server memory. Cleaned some code.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d24b3042..f63ef660 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,8 +18,8 @@ tmwserv_account_SOURCES = \
account-server/accountclient.cpp \
account-server/accounthandler.hpp \
account-server/accounthandler.cpp \
- account-server/characterdata.hpp \
- account-server/characterdata.cpp \
+ account-server/character.hpp \
+ account-server/character.cpp \
account-server/dalstorage.hpp \
account-server/dalstorage.cpp \
account-server/dalstoragesql.hpp \
@@ -29,8 +29,6 @@ tmwserv_account_SOURCES = \
account-server/guildmanager.h \
account-server/serverhandler.hpp \
account-server/serverhandler.cpp \
- account-server/storage.hpp \
- account-server/storage.cpp \
chat-server/chathandler.hpp \
chat-server/chathandler.cpp \
chat-server/chatclient.hpp \
@@ -55,7 +53,6 @@ tmwserv_account_SOURCES = \
net/netcomputer.hpp \
net/netcomputer.cpp \
serialize/characterdata.hpp \
- utils/countedptr.h \
utils/functors.h \
utils/logger.h \
utils/logger.cpp \