summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-01-03 17:10:43 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-01-03 17:10:43 +0000
commit1673de8b5553f6dcd4898c84b8d44ba8b30740f1 (patch)
tree3dcc47461a6b4914c4e81492e7be885c3a1502ea /src/Makefile.am
parent6b7441516002d6e7cca424416bb67c6bc7d7c9d2 (diff)
downloadmanaserv-1673de8b5553f6dcd4898c84b8d44ba8b30740f1.tar.gz
manaserv-1673de8b5553f6dcd4898c84b8d44ba8b30740f1.tar.bz2
manaserv-1673de8b5553f6dcd4898c84b8d44ba8b30740f1.tar.xz
manaserv-1673de8b5553f6dcd4898c84b8d44ba8b30740f1.zip
Split persistent player data from game server data. Enabled inventory code back.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 12 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 759927e5..255b25e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,17 +6,10 @@ bin_PROGRAMS = tmwserv-account tmwserv-game
tmwserv_account_SOURCES = \
account-server/main-account.cpp \
- being.h \
configuration.h \
configuration.cpp \
- debug.h \
- debug.cpp \
defines.h \
- inventory.h \
- item.h \
- object.h \
- player.h \
- player.cpp \
+ playerdata.hpp \
point.h \
resourcemanager.h \
resourcemanager.cpp \
@@ -70,25 +63,14 @@ tmwserv_account_SOURCES = \
tmwserv_game_SOURCES = \
game-server/main-game.cpp \
- being.h \
- being.cpp \
configuration.h \
configuration.cpp \
controller.h \
controller.cpp \
- debug.h \
- debug.cpp \
defines.h \
- inventory.h \
- inventory.cpp \
item.h \
item.cpp \
- map.h \
- map.cpp \
- object.h \
- object.cpp \
- player.h \
- player.cpp \
+ playerdata.hpp \
point.h \
resourcemanager.h \
resourcemanager.cpp \
@@ -96,16 +78,26 @@ tmwserv_game_SOURCES = \
skill.cpp \
game-server/accountconnection.hpp \
game-server/accountconnection.cpp \
+ game-server/being.hpp \
+ game-server/being.cpp \
game-server/gamehandler.hpp \
game-server/gamehandler.cpp \
+ game-server/inventory.hpp \
+ game-server/inventory.cpp \
game-server/itemmanager.hpp \
game-server/itemmanager.cpp \
+ game-server/map.hpp \
+ game-server/map.cpp \
game-server/mapcomposite.hpp \
game-server/mapcomposite.cpp \
game-server/mapmanager.hpp \
game-server/mapmanager.cpp \
game-server/mapreader.hpp \
game-server/mapreader.cpp \
+ game-server/object.hpp \
+ game-server/object.cpp \
+ game-server/player.hpp \
+ game-server/player.cpp \
game-server/state.hpp \
game-server/state.cpp \
game-server/testing.cpp \