summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-05-13 18:12:22 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-05-13 18:12:22 +0000
commit87be1a8a52a5485d1cf90240cbf628004cbd5350 (patch)
tree5b165cc291021acdca249b040b47656093d7fea7 /configure.ac
parentc01baa046b6cfdfe8da438d3e60d6cfa141a674f (diff)
downloadmanaserv-87be1a8a52a5485d1cf90240cbf628004cbd5350.tar.gz
manaserv-87be1a8a52a5485d1cf90240cbf628004cbd5350.tar.bz2
manaserv-87be1a8a52a5485d1cf90240cbf628004cbd5350.tar.xz
manaserv-87be1a8a52a5485d1cf90240cbf628004cbd5350.zip
Applied patch by Guillaume Melquiond which adds ENet check and adds timer.cpp/h
to the Makefile.am. Also fixed some compilation warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fce7423..13504d55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,9 @@ AC_MSG_ERROR([ *** Unable to find PhysFS library (icculus.org/physfs/)]))
AC_CHECK_LIB([SDL_net], [SDLNet_Init], ,
AC_MSG_ERROR([ *** Unable to find SDL_net library]))
+AC_CHECK_LIB([enet], [enet_initialize], ,
+AC_MSG_ERROR([ *** Unable to find enet library (enet.bespin.org)]))
+
PKG_CHECK_MODULES(XML2, [libxml-2.0 >= 2.4])
CXXFLAGS="$CXXFLAGS $XML2_CFLAGS"
LIBS="$LIBS $XML2_LIBS"