summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2006-08-02 12:41:35 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-01-05 21:36:33 +0100
commitce0d7b62824d620ec8c3daceac5710fbbd6b12f1 (patch)
tree91e86ed20d398962dee82b75dc10dba5f0f9f233 /src/Makefile.am
parent090b4893a57a1b7e9c83f7db043843d35016fcff (diff)
downloadmana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.gz
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.bz2
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.tar.xz
mana-client-ce0d7b62824d620ec8c3daceac5710fbbd6b12f1.zip
Cleaned autotools files
Put object files in subdirectories. Moved compilation flags to configure script. Added library header checks. (cherry picked from mainline commit 0bebbc320d50178a7ece573319cd6687a950dafa)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4ef07773..7c547a11 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
bin_PROGRAMS = tmw
tmw_SOURCES = gui/widgets/resizegrip.cpp \
gui/widgets/resizegrip.h \
@@ -310,9 +312,3 @@ tmw_SOURCES = gui/widgets/resizegrip.cpp \
INCLUDES = \
$(all_includes) \
-DTMW_DATADIR=\""$(pkgdatadir)/"\"
-
-# the library search path.
-tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
-tmw_CXXFLAGS = -Wall $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0` $(CURL_CFLAGS)
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl $(CURL_LIBS)
-tmw_TARGET = tmw