summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Sehmisch <crush@themanaworld.org>2009-01-06 17:00:25 +0100
committerPhilipp Sehmisch <crush@themanaworld.org>2009-01-06 17:00:25 +0100
commit791ec19aa351df7d5d1ecc3bc6007ba512c05488 (patch)
treeab17df5c3d67389d0dc08733570edeeb7a9c9999 /src/Makefile.am
parent6b60673b0805fbab747924d1a0b6d9c66fc96f64 (diff)
parented39006cfe36e01f68d13a59d1109db905997efc (diff)
downloadmana-client-791ec19aa351df7d5d1ecc3bc6007ba512c05488.tar.gz
mana-client-791ec19aa351df7d5d1ecc3bc6007ba512c05488.tar.bz2
mana-client-791ec19aa351df7d5d1ecc3bc6007ba512c05488.tar.xz
mana-client-791ec19aa351df7d5d1ecc3bc6007ba512c05488.zip
Merge branch 'master' of git@gitorious.org:tmw/eathena
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4ef07773..c924760f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
bin_PROGRAMS = tmw
tmw_SOURCES = gui/widgets/resizegrip.cpp \
gui/widgets/resizegrip.h \
@@ -213,6 +215,7 @@ tmw_SOURCES = gui/widgets/resizegrip.cpp \
utils/base64.h \
utils/dtor.h \
utils/fastsqrt.h \
+ utils/gettext.h \
utils/strprintf.cpp \
utils/strprintf.h \
utils/tostring.h \
@@ -309,10 +312,5 @@ tmw_SOURCES = gui/widgets/resizegrip.cpp \
# set the include path found by configure
INCLUDES = \
$(all_includes) \
- -DTMW_DATADIR=\""$(pkgdatadir)/"\"
-
-# the library search path.
-tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
-tmw_CXXFLAGS = -Wall $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0` $(CURL_CFLAGS)
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl $(CURL_LIBS)
-tmw_TARGET = tmw
+ -DTMW_DATADIR=\""$(pkgdatadir)/"\" \
+ -DLOCALEDIR=\""$(localedir)"\"