summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2006-08-02 12:41:35 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2006-08-02 12:41:35 +0000
commit0bebbc320d50178a7ece573319cd6687a950dafa (patch)
tree751edf5d7dfcb8a6cd67bd1531d8151c56eedace /src/Makefile.am
parent2f55e567a965bd315f191b51986038b2daf45525 (diff)
downloadmana-client-0bebbc320d50178a7ece573319cd6687a950dafa.tar.gz
mana-client-0bebbc320d50178a7ece573319cd6687a950dafa.tar.bz2
mana-client-0bebbc320d50178a7ece573319cd6687a950dafa.tar.xz
mana-client-0bebbc320d50178a7ece573319cd6687a950dafa.zip
Cleaned autotools files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 42e72829..13ec7308 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
bin_PROGRAMS = tmw
tmw_SOURCES = graphic/imagerect.h \
gui/browserbox.cpp \
@@ -240,9 +242,3 @@ tmw_SOURCES = graphic/imagerect.h \
INCLUDES = \
$(all_includes) \
-DTMW_DATADIR=\""$(pkgdatadir)/"\"
-
-# the library search path.
-tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
-tmw_CXXFLAGS = -Wall -Werror $(OPENGL_CFLAGS) $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0` $(CURL_CFLAGS)
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl $(OPENGL_LIBS) $(CURL_LIBS)
-tmw_TARGET = tmw