summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2008-12-03 12:30:11 -0700
committerIra Rice <irarice@gmail.com>2008-12-03 12:30:11 -0700
commit68926c15e6d31c4af90bce9ec57aa39f839d7d6b (patch)
tree18fc1553fabfe16022950facf16422afd191fa01 /src/CMakeLists.txt
parent414afae670d09e34a4b5c0528c9ca6c3abb03124 (diff)
downloadmana-client-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.gz
mana-client-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.bz2
mana-client-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.xz
mana-client-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.zip
Add an effects manager (patch by Kage Jittai)
NOTE: This patch demonstrates the need to fix pixel coordinates in the eAthena client. Bjorn did the movement patch in the TMWClient, however, I still haven't got that fully working with the merges. It's likely that a clone will be developed to tackle this problem. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e4803230..4e8654e6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -342,6 +342,8 @@ SET(SRCS
textparticle.h
tileset.h
vector.h
+ effectmanager.cpp
+ effectmanager.h
)
ADD_EXECUTABLE(aethyra ${SRCS})