summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2009-03-14 13:21:35 -0600
committerIra Rice <irarice@gmail.com>2009-03-14 13:21:35 -0600
commit3575c7a606c2d24c0d444e9999892c0390fa5ae8 (patch)
tree399bd2ce51577aa721a460884b397f52d4a4590c /src/CMakeLists.txt
parentf0c6bed3d879e1c7b9a6d5b7e676a4f1c6a29a54 (diff)
downloadmana-client-3575c7a606c2d24c0d444e9999892c0390fa5ae8.tar.gz
mana-client-3575c7a606c2d24c0d444e9999892c0390fa5ae8.tar.bz2
mana-client-3575c7a606c2d24c0d444e9999892c0390fa5ae8.tar.xz
mana-client-3575c7a606c2d24c0d444e9999892c0390fa5ae8.zip
Made a label class derived from the guichan label class which utilizes
the palette colors. While technically, this can be accomplished through other means, it's rather clumsy overall, and is prone to introducing in programmer errors. This commit finally catches every case where text is used, and applies the text color from the color dialog to each of them appropriately. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7025c2c4..93bac9ae 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -117,6 +117,8 @@ SET(SRCS
gui/itemshortcutcontainer.h\
gui/item_amount.cpp
gui/item_amount.h
+ gui/label.cpp
+ gui/label.h
gui/linkhandler.h
gui/listbox.cpp
gui/listbox.h