summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-10 14:39:16 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-10 14:39:16 +0000
commit2136d196ef0e1dbb6d085c163443d83ec0766610 (patch)
tree5dd19a7f0b782f7e566cc6460caf6a5807ce3311 /configure.in
parentd7e809c18ce55830fdc87eba29f30a6dfc4f222d (diff)
downloadmana-client-2136d196ef0e1dbb6d085c163443d83ec0766610.tar.gz
mana-client-2136d196ef0e1dbb6d085c163443d83ec0766610.tar.bz2
mana-client-2136d196ef0e1dbb6d085c163443d83ec0766610.tar.xz
mana-client-2136d196ef0e1dbb6d085c163443d83ec0766610.zip
Fixed PlayerBox to cope with no hair as well, and fixed using Makefile.cvs a
bit, to generate the configure.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index c28be9bb..ff50361a 100755
--- a/configure.in
+++ b/configure.in
@@ -10,11 +10,10 @@ AC_PATH_PROGS(INSTALL, install ginstall, install)
AC_PATH_PROG(CHMOD, chmod, chmod)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(tmw, 0.8.0)
+AM_INIT_AUTOMAKE(tmw, 0.0.9)
AC_LANG_CPLUSPLUS
AC_PROG_CXX
-AM_PROG_LIBTOOL
dnl FIND_PATH(programm-name, variable-name, list of directories,
dnl if-not-found, test-parameter)
@@ -85,15 +84,6 @@ FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/loca
if test -n "$LIBSDL_CONFIG"; then
LIBSDL_LIBS="`$LIBSDL_CONFIG --libs` -lSDL_image -lSDL_mixer"
- LIBSDL_RPATH=
- for args in $LIBSDL_LIBS; do
- case $args in
- -L*)
- LIBSDL_RPATH="$LIBSDL_RPATH $args"
- ;;
- esac
- done
- LIBSDL_RPATH=`echo $LIBSDL_RPATH | sed -e "s/-L/-R/g"`
LIBSDL_CFLAGS="`$LIBSDL_CONFIG --cflags`"
AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 1, [Defines if your system has the LIBSDL library])
@@ -103,6 +93,5 @@ fi
AC_SUBST(LIBSDL_LIBS)
AC_SUBST(LIBSDL_CFLAGS)
-AC_SUBST(LIBSDL_RPATH)
AC_OUTPUT(Makefile src/Makefile)