summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-08-20 10:31:46 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-08-20 10:31:46 +0000
commite8c3de13e9f850498b9ab2dfaca758c851566d3a (patch)
treea8a5906cf7fc2966d292a1337ab73bd4f20fd8d0 /configure.ac
parent2b4d8d1323883ab814997f8cd4e984e53919b68e (diff)
downloadmana-client-e8c3de13e9f850498b9ab2dfaca758c851566d3a.tar.gz
mana-client-e8c3de13e9f850498b9ab2dfaca758c851566d3a.tar.bz2
mana-client-e8c3de13e9f850498b9ab2dfaca758c851566d3a.tar.xz
mana-client-e8c3de13e9f850498b9ab2dfaca758c851566d3a.zip
Moved libpng check before SDL_image check, since the latter requires the former.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6c1d571f..c0816aa7 100755
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,9 @@ AC_SUBST(CURL_CFLAGS)
AC_CHECK_LIB([xml2], [xmlInitParser], ,
AC_MSG_ERROR([ *** Unable to find libxml2 library (xmlsoft.org)]))
+AC_CHECK_LIB(png, png_write_info, ,
+AC_MSG_ERROR([ *** Unable to find png library]))
+
AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
(http://www.libsdl.org/projects/SDL_image/)]))
@@ -60,9 +63,6 @@ AC_MSG_ERROR([ *** Unable to find SDL_mixer library
AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
AC_MSG_ERROR([ *** Unable to find SDL_net library]))
-AC_CHECK_LIB(png, png_write_info, ,
-AC_MSG_ERROR([ *** Unable to find png library]))
-
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])