summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-13 00:41:52 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-13 00:41:52 +0000
commitdc453f0c21c35aa3cd4ff6f9550f429833c6ddd7 (patch)
treefa1b8f1300e561169d2e1aaf37cae58230792a5c /configure.ac
parent85f211ea50df2d48c0400b2a267808f798b524fa (diff)
downloadmana-client-dc453f0c21c35aa3cd4ff6f9550f429833c6ddd7.tar.gz
mana-client-dc453f0c21c35aa3cd4ff6f9550f429833c6ddd7.tar.bz2
mana-client-dc453f0c21c35aa3cd4ff6f9550f429833c6ddd7.tar.xz
mana-client-dc453f0c21c35aa3cd4ff6f9550f429833c6ddd7.zip
Fail configure when Guichan cannot be found.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4aab0ff5..e627f1f1 100755
--- a/configure.ac
+++ b/configure.ac
@@ -11,14 +11,17 @@ AC_PROG_MAKE_SET
# Checks for libraries
# (someone may want to exchange these symbols with
-# soemthing more meaningful in the future /- kth5)
-AC_CHECK_LIB([guichan], [_init])
-AC_CHECK_LIB([guichan_sdl], [_init])
+# something more meaningful in the future /- kth5)
+AC_CHECK_LIB([guichan], [_init], ,
+AC_MSG_ERROR([ *** Unable to find Guichan library (guichan.darkbits.org)]))
+
+AC_CHECK_LIB([guichan_sdl], [_init], ,
+AC_MSG_ERROR([ *** Unable to find Guichan SDL library (guichan.darkbits.org)]))
-# Check for SDL_image and SDL_mixer library
AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
(http://www.libsdl.org/projects/SDL_image/)]))
+
AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio, ,
AC_MSG_ERROR([ *** Unable to find SDL_mixer library
(http://www.libsdl.org/projects/SDL_mixer/)]))