summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-03-05 14:52:33 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-03-05 14:52:33 +0000
commita4cf076756e8d69879a9489dc8a4e38d6900c786 (patch)
treea84b8e7634e6842d06094384a306013f5411e80a /configure.ac
parente8cf7d5436f7b525e79b9d5949e34bc5f8024fa0 (diff)
downloadmana-client-a4cf076756e8d69879a9489dc8a4e38d6900c786.tar.gz
mana-client-a4cf076756e8d69879a9489dc8a4e38d6900c786.tar.bz2
mana-client-a4cf076756e8d69879a9489dc8a4e38d6900c786.tar.xz
mana-client-a4cf076756e8d69879a9489dc8a4e38d6900c786.zip
Updates to INSTALL and added lib checks to configure.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8accc8b..54d4ab61 100755
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,12 @@ AC_MSG_ERROR([ *** Unable to find Guichan library (guichan.darkbits.org)]))
AC_CHECK_LIB([guichan_sdl], [_init], ,
AC_MSG_ERROR([ *** Unable to find Guichan SDL library (guichan.darkbits.org)]))
+AC_CHECK_LIB([physfs], [PHYSFS_init], ,
+AC_MSG_ERROR([ *** Unable to find PhysFS library (icculus.org/physfs/)]))
+
+AC_CHECK_LIB([xml2], [xmlInitParser], ,
+AC_MSG_ERROR([ *** Unable to find libxml2 library (xmlsoft.org)]))
+
AC_CHECK_LIB(SDL_image, IMG_LoadPNG_RW, ,
AC_MSG_ERROR([ *** Unable to find SDL_image library with PNG support
(http://www.libsdl.org/projects/SDL_image/)]))