summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
committerRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
commitf61fc8ef256f43d1ada47fb5851f8954fea4cdea (patch)
tree210b0ad30ed690b63576da561954091987622fb3 /Makefile.am
parent893cde9e754b805f1e62c517740919c04d9490e0 (diff)
downloadmana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.gz
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.bz2
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.xz
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.zip
- Added installation of game data, install required on *nix systems
- Updated desktop file to work better - Install the desktop file to the standard location - Install the icon as tmw.png in the standard pixmaps data dir
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 76263c6e..7306c71f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,9 @@
-# Subdirectories to include in a distribution
-DIST_SUBDIRS = src data docs
-
# Subdirectories to build
-SUBDIRS = src
+SUBDIRS = data docs src
+
+desktopdir = $(datadir)/applications
+
+desktop_DATA = tmw.desktop
# Extra files to include
-EXTRA_DIST = tmw.desktop
+EXTRA_DIST = $(desktop_DATA)