summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFreeyorp <TheFreeYorp+git@gmail.com>2024-06-19 12:58:58 +0000
committerFreeyorp <TheFreeYorp+git@gmail.com>2024-06-19 13:00:17 +0000
commit8a6da3aae88d4976fca21138a4d0bcfc1a1a40af (patch)
tree7f754ede906880956206179272822ec9b4dcf041 /CMakeLists.txt
parent70ca9f9fa9adb60014e1c7f6e420c327ecd94a39 (diff)
downloadtmwa-one-time-black-magic.tar.gz
tmwa-one-time-black-magic.tar.bz2
tmwa-one-time-black-magic.tar.xz
tmwa-one-time-black-magic.zip
WIP: ODR warning investigationone-time-black-magic
This attempts to establish an upper bound for an isolated test case, using `NotAccountEmail` instead of `AccountEmail`. The warning is not currently triggered by building this psuedo-server.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79413ee..73a10a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,7 +53,7 @@ set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS
# For each subfolder in src, add all .cpp files to a subfolder's SOURCES
# variable.
set(ALL_SOURCES "")
-foreach(dir admin ast char compat conf generic high ints io login map mmo net proto-base range sexpr shared strings tests wire strtest)
+foreach(dir admin ast char compat conf generic high ints io login map mmo net proto-base range sexpr shared strings tests wire strtest teststorageclass)
file(GLOB_RECURSE ${dir}_SOURCES CONFIGURE_DEPENDS src/${dir}/*.cpp)
# Exclude any _test.cpp files from the build
set(ALL_SOURCES ${ALL_SOURCES} ${${dir}_SOURCES})
@@ -168,6 +168,16 @@ add_executable(tmwa-admin ${admin_SOURCES}
)
target_link_libraries(tmwa-admin tmwa-shared)
+add_executable(tmwa-teststorageclass ${teststorageclass_SOURCES}
+ ${generic_SOURCES}
+ ${high_SOURCES}
+ ${io_SOURCES}
+ ${mmo_SOURCES}
+ ${net_SOURCES}
+ ${wire_SOURCES}
+)
+target_link_libraries(tmwa-teststorageclass tmwa-shared)
+
# TODO: Call make -f ${CMAKE_SOURCE_DIR}/generate.mk clean to clean up the
# generated files. We want this to be run every time we call make clean.