summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..db30276
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python3
+
+from distutils.core import setup
+
+from attoconf.version import part_version
+
+setup(
+ name='attoconf',
+ version=part_version,
+ description='A small and sensible replacement for GNU autoconf',
+ author='Ben Longbons',
+ author_email='b.r.longbons@gmail.com',
+ url='http://github.com/o11c/attoconf',
+ packages=[
+ 'attoconf',
+ 'attoconf.lib',
+ ],
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Programming Language :: Python :: 2 :: Only',
+ 'Topic :: Software Development :: Build Tools',
+ ],
+)