summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-10-25 22:00:39 +0300
committerAndrei Karas <akaras@inbox.ru>2017-10-25 22:00:39 +0300
commit31de1563a480777460ab303af929464db3f80776 (patch)
tree6c2e37920bfa64291ccabb3b7a737a913f75182c /src/Makefile.am
parent7bbd39e0da04cee932f4afe6a4c85ebb78f39a81 (diff)
downloadManaVerse-31de1563a480777460ab303af929464db3f80776.tar.gz
ManaVerse-31de1563a480777460ab303af929464db3f80776.tar.bz2
ManaVerse-31de1563a480777460ab303af929464db3f80776.tar.xz
ManaVerse-31de1563a480777460ab303af929464db3f80776.zip
Add configure options for build only tests binary with system catch and doctest.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1b7ccd77f..1f31e0f51 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,9 +37,16 @@ endif
if ENABLE_UNITTESTSBIN_DOCTEST
manaplustests_CXXFLAGS += -DUNITTESTS_DOCTEST
endif
+if ENABLE_UNITTESTSBIN
+if ENABLE_UNITTESTSBIN_EMBED
+manaplustests_CXXFLAGS += -DUNITTESTS_EMBED
+endif
+endif
+if ENABLE_UNITTESTS
if ENABLE_UNITTESTS_EMBED
manaplustests_CXXFLAGS += -DUNITTESTS_EMBED
endif
+endif
dyecmd_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
-DLOCALEDIR=\""$(localedir)"\" \