summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2008-12-29 14:02:01 -0700
committerIra Rice <irarice@gmail.com>2008-12-29 14:06:41 -0700
commita5c8eae057746618443c788fcaa04221d8ad7ba4 (patch)
treeab104a2dd1f931730eef50365434b8ac0896ca8b /src/Makefile.am
parent6b680b60af9084767fd50737df763a89ca2c2919 (diff)
downloadMana-a5c8eae057746618443c788fcaa04221d8ad7ba4.tar.gz
Mana-a5c8eae057746618443c788fcaa04221d8ad7ba4.tar.bz2
Mana-a5c8eae057746618443c788fcaa04221d8ad7ba4.tar.xz
Mana-a5c8eae057746618443c788fcaa04221d8ad7ba4.zip
Added support for True Type Fonts using GUIChan's inbuilt SDLTrueType
class. NOTE: This commit adds a brand new dependency (SDL_TTF). Make sure to install it, regenerate your config files, reconfigure, and then install before attempting to compile. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5f168dda..f6b343f6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -74,6 +74,8 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
gui/npc_text.h \
gui/ok_dialog.cpp \
gui/ok_dialog.h \
+ gui/truetypefont.cpp \
+ gui/truetypefont.h \
gui/passwordfield.cpp \
gui/passwordfield.h \
gui/playerbox.cpp \
@@ -301,6 +303,8 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
properties.h \
recorder.cpp \
recorder.h \
+ sdltruetypefont.cpp \
+ sdltruetypefont.h \
serverinfo.h \
shopitem.cpp \
shopitem.h \