summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2008-12-05 21:38:31 +0100
committerIra Rice <irarice@gmail.com>2008-12-05 15:55:14 -0700
commit7d5bfc11b5e467b502a3b56e853200b887859808 (patch)
tree4efe49ce0b3e830911700be9d249ce678b3f99cd /src/Makefile.am
parent4eec3f17deafad4ed2fc28fae76fe1f4994e3076 (diff)
downloadMana-7d5bfc11b5e467b502a3b56e853200b887859808.tar.gz
Mana-7d5bfc11b5e467b502a3b56e853200b887859808.tar.bz2
Mana-7d5bfc11b5e467b502a3b56e853200b887859808.tar.xz
Mana-7d5bfc11b5e467b502a3b56e853200b887859808.zip
Fix race condition with a std::string access
The downloading thread was writing to a std::string while the main thread was trying to draw it, for example. Now access to the label caption is guarded with a mutex. Should fix crashes while downloading updates.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 76773d49..75434d8e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -229,6 +229,7 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
utils/strprintf.h \
utils/tostring.h \
utils/trim.h \
+ utils/mutex.h \
utils/xml.cpp \
utils/xml.h \
animatedsprite.cpp \