summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2008-12-05 21:38:31 +0100
committerBjørn Lindeijer <bjorn@lindeijer.nl>2008-12-05 22:01:28 +0100
commit6ac9c3bce62a8fc79e23477417188108f0ad9fa6 (patch)
tree70484c9e8520d6a7e88992b7038fd08f1e943f13 /src/Makefile.am
parent36ae10688b870c4d6029e20ef9a063a2db120e6a (diff)
downloadMana-6ac9c3bce62a8fc79e23477417188108f0ad9fa6.tar.gz
Mana-6ac9c3bce62a8fc79e23477417188108f0ad9fa6.tar.bz2
Mana-6ac9c3bce62a8fc79e23477417188108f0ad9fa6.tar.xz
Mana-6ac9c3bce62a8fc79e23477417188108f0ad9fa6.zip
Fix race condition with a std::string access
The downloading thread was writing to a std::string while the main thread was trying to draw it, for example. Now access to the label caption is guarded with a mutex. Should fix crashes while downloading updates.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 867953ab..3387690a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -219,6 +219,7 @@ tmw_SOURCES = gui/widgets/resizegrip.cpp \
utils/strprintf.h \
utils/tostring.h \
utils/trim.h \
+ utils/mutex.h \
utils/xml.cpp \
utils/xml.h \
animatedsprite.cpp \