summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2008-12-03 12:30:11 -0700
committerIra Rice <irarice@gmail.com>2008-12-03 12:30:11 -0700
commit68926c15e6d31c4af90bce9ec57aa39f839d7d6b (patch)
tree18fc1553fabfe16022950facf16422afd191fa01 /src/Makefile.am
parent414afae670d09e34a4b5c0528c9ca6c3abb03124 (diff)
downloadMana-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.gz
Mana-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.bz2
Mana-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.tar.xz
Mana-68926c15e6d31c4af90bce9ec57aa39f839d7d6b.zip
Add an effects manager (patch by Kage Jittai)
NOTE: This patch demonstrates the need to fix pixel coordinates in the eAthena client. Bjorn did the movement patch in the TMWClient, however, I still haven't got that fully working with the merges. It's likely that a clone will be developed to tackle this problem. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c759135..76773d49 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -242,6 +242,8 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
configlistener.h \
configuration.cpp \
configuration.h \
+ effectmanager.cpp \
+ effectmanager.h \
engine.cpp \
engine.h \
equipment.cpp \
@@ -313,6 +315,7 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
textparticle.cpp \
textparticle.h \
tileset.h \
+ vector.cpp \
vector.h
# set the include path found by configure