summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-04 11:20:54 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-04 11:20:54 +0000
commiteccafb8d815068d908b998bb6c0b581b076dc78f (patch)
tree6967d3ca5fa1dc77b177c2f735469503ca04cd14 /src/CMakeLists.txt
parent061b9e817ffe73acca163510b276e6ca7dd8f6c2 (diff)
downloadMana-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.gz
Mana-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.bz2
Mana-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.xz
Mana-eccafb8d815068d908b998bb6c0b581b076dc78f.zip
Introduced a new class Viewport which combines the drawing code from Engine
with the (rather misplaced) input handling from the Gui class. Also, it's a Container itself which should allow for extending it to show Guichan widgets on map coordinates.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt24
1 files changed, 13 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cd207dbe..b6a77e27 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -145,6 +145,8 @@ SET(SRCS
gui/textfield.h
gui/trade.cpp
gui/trade.h
+ gui/viewport.cpp
+ gui/viewport.h
gui/window.cpp
gui/window.h
gui/windowcontainer.cpp
@@ -199,23 +201,23 @@ SET(SRCS
net/tradehandler.h
resources/ambientoverlay.cpp
resources/ambientoverlay.h
- resources/equipmentdb.cpp
- resources/equipmentdb.h
- resources/equipmentinfo.h
+ resources/equipmentdb.cpp
+ resources/equipmentdb.h
+ resources/equipmentinfo.h
resources/image.cpp
resources/image.h
resources/imagewriter.cpp
resources/imagewriter.h
- resources/itemdb.cpp
- resources/itemdb.h
- resources/iteminfo.h
- resources/iteminfo.cpp
+ resources/itemdb.cpp
+ resources/itemdb.h
+ resources/iteminfo.h
+ resources/iteminfo.cpp
resources/mapreader.cpp
resources/mapreader.h
resources/monsterdb.h
- resources/monsterdb.cpp
- resources/monsterinfo.h
- resources/monsterinfo.cpp
+ resources/monsterdb.cpp
+ resources/monsterinfo.h
+ resources/monsterinfo.cpp
resources/music.h
resources/music.cpp
resources/openglsdlimageloader.h
@@ -315,4 +317,4 @@ TARGET_LINK_LIBRARIES(tmw
INSTALL(TARGETS tmw RUNTIME DESTINATION ${PKG_BINDIR})
-SET_TARGET_PROPERTIES(tmw PROPERTIES COMPILE_FLAGS "${FLAGS}") \ No newline at end of file
+SET_TARGET_PROPERTIES(tmw PROPERTIES COMPILE_FLAGS "${FLAGS}")