summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-01-22 18:31:25 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-01-24 19:05:14 +0100
commitdd1386684b6430337d3b270bec1ca53fa69f9593 (patch)
tree68ec0caa9e81af7ebd38f45e4a9fcbf8ed35625c /src/CMakeLists.txt
parent8a4b82e3ed75e426d44b69640f009e1e731c75c4 (diff)
downloadMana-dd1386684b6430337d3b270bec1ca53fa69f9593.tar.gz
Mana-dd1386684b6430337d3b270bec1ca53fa69f9593.tar.bz2
Mana-dd1386684b6430337d3b270bec1ca53fa69f9593.tar.xz
Mana-dd1386684b6430337d3b270bec1ca53fa69f9593.zip
Use SDL_RWops directly on top of PhysFS
This avoids the creation of a temporary buffer containing a complete file for the sole purpose of wrapping it up in an SDL_RWops. The necessary wrapper is by Ryan C. Gordon and is included in the PhysFS repository under 'extras'. Reviewed-by: Yohann Ferreira
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 575a00f0..895fd349 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -412,6 +412,8 @@ SET(SRCS
utils/dtor.h
utils/gettext.h
utils/mathutils.h
+ utils/physfsrwops.c
+ utils/physfsrwops.h
utils/sha256.cpp
utils/sha256.h
utils/stringutils.cpp