summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-02-24 21:16:12 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-03-24 22:28:23 +0100
commita5690fa2a4cce2698225f1f558183f6fe306d860 (patch)
tree822d4e237412afd38008de04d9be11fd0718f101 /src/CMakeLists.txt
parent054246ebffcdd20da72a8e464b40eaf64d484743 (diff)
downloadMana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.gz
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.bz2
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.xz
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.zip
Introduced compile-time option to disable use of C++0x
This is in order to still support older compilers, in particular GCC 4.2.1, so that Mana may be compiled for Maemo 5. Reviewed-by: Yohann Ferreira
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 977524e9..e0a42478 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -34,7 +34,11 @@ ENDIF()
SET(FLAGS "-DPACKAGE_VERSION=\\\"${VERSION}\\\"")
SET(FLAGS "${FLAGS} -DPKG_DATADIR=\\\"${PKG_DATADIR}/\\\"")
SET(FLAGS "${FLAGS} -DLOCALEDIR=\\\"${LOCALEDIR}/\\\"")
-SET(FLAGS "${FLAGS} -std=c++0x")
+IF (ENABLE_CPP0X)
+ SET(FLAGS "${FLAGS} -std=c++0x -DENABLE_CPP0X=1")
+ELSE()
+ INCLUDE_DIRECTORIES("cpp0x_compat")
+ENDIF()
IF (ENABLE_NLS)
SET(FLAGS "${FLAGS} -DENABLE_NLS=1")