summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2007-06-04 21:48:47 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2007-06-04 21:48:47 +0000
commita353543dd4da3c489a84f6f17125fdd0e1be2349 (patch)
tree5e447a0f9a3fd50f58a48f39bbb77d392d78af36 /src/CMakeLists.txt
parentab072dddb231895ba7b6762eda9fa70af961b0fb (diff)
downloadMana-a353543dd4da3c489a84f6f17125fdd0e1be2349.tar.gz
Mana-a353543dd4da3c489a84f6f17125fdd0e1be2349.tar.bz2
Mana-a353543dd4da3c489a84f6f17125fdd0e1be2349.tar.xz
Mana-a353543dd4da3c489a84f6f17125fdd0e1be2349.zip
Merged 0.0 changes from revision 3234 to 3317 to trunk.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e28e235e..7a4da70d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,6 +47,8 @@ MARK_AS_ADVANCED(SDL_INCLUDE_DIR)
MARK_AS_ADVANCED(SDL_LIBRARY)
SET(SRCS
+ gui/widgets/resizegrip.cpp
+ gui/widgets/resizegrip.h
gui/box.cpp
gui/box.h
gui/browserbox.cpp
@@ -275,11 +277,15 @@ SET(SRCS
utils/base64.cpp
utils/base64.h
utils/dtor.h
+ utils/fastsqrt.h
+ utils/minmax.h
utils/tostring.h
utils/xml.cpp
utils/xml.h
animatedsprite.cpp
animatedsprite.h
+ animationparticle.cpp
+ animationparticle.h
being.cpp
being.h
beingmanager.cpp
@@ -304,6 +310,8 @@ SET(SRCS
graphics.cpp
graphics.h
guichanfwd.h
+ imageparticle.cpp
+ imageparticle.h
inventory.cpp
inventory.h
item.cpp
@@ -326,6 +334,10 @@ SET(SRCS
npc.h
openglgraphics.cpp
openglgraphics.h
+ particle.cpp
+ particle.h
+ particleemitter.cpp
+ particleemitter.h
player.cpp
player.h
properties.h
@@ -335,6 +347,8 @@ SET(SRCS
sound.cpp
sound.h
sprite.h
+ textparticle.cpp
+ textparticle.h
tileset.h
)