summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJared Adams <jaxad0127@gmail.com>2010-05-02 14:43:40 -0600
committerJared Adams <jaxad0127@gmail.com>2010-05-06 22:21:57 -0600
commit9baedc27191c82bbf1fedee2a7e738bc5b267c0e (patch)
treef0986c6839d1e79b402d5d4ec36e4994741955ea /src/CMakeLists.txt
parent844e9a7a72faca6a212e788a3adc45e17f41dca6 (diff)
downloadMana-9baedc27191c82bbf1fedee2a7e738bc5b267c0e.tar.gz
Mana-9baedc27191c82bbf1fedee2a7e738bc5b267c0e.tar.bz2
Mana-9baedc27191c82bbf1fedee2a7e738bc5b267c0e.tar.xz
Mana-9baedc27191c82bbf1fedee2a7e738bc5b267c0e.zip
Add support for floor item sprites
This commit adds a sprite hierarchy (Sprite->ImageSprite,AnimatedSprite,CompundSprite; CompoundSprite,Actor->ActorSprite;ActorSprite->Being,FloorItem) to collect common functionailty into new base classes which will make other Mantis tickets easier to do. Also allows monsters to use particle effects. Reviewed-by: Bertram
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 433a1d3d..6ccdd4e2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -402,6 +402,8 @@ SET(SRCS
utils/xml.h
actor.cpp
actor.h
+ actorsprite.cpp
+ actorsprite.h
animatedsprite.cpp
animatedsprite.h
animationparticle.cpp
@@ -422,6 +424,8 @@ SET(SRCS
channelmanager.h
commandhandler.cpp
commandhandler.h
+ compoundsprite.cpp
+ compoundsprite.h
configlistener.h
configuration.cpp
configuration.h
@@ -443,6 +447,8 @@ SET(SRCS
guild.h
imageparticle.cpp
imageparticle.h
+ imagesprite.cpp
+ imagesprite.h
inventory.cpp
inventory.h
item.cpp
@@ -491,6 +497,7 @@ SET(SRCS
simpleanimation.h
sound.cpp
sound.h
+ sprite.h
statuseffect.cpp
statuseffect.h
text.cpp