summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJared Adams <jaxad0127@gmail.com>2010-08-13 14:45:52 -0600
committerJared Adams <jaxad0127@gmail.com>2010-08-13 18:43:16 -0600
commit8eadc834ed3e8439836f7dc87390a56a1164ec11 (patch)
tree36cf9915914517b137d488a40d1f61265867723d /src/CMakeLists.txt
parent6d315d0e61f419636021476582a49ab0b1f1b5e9 (diff)
downloadMana-8eadc834ed3e8439836f7dc87390a56a1164ec11.tar.gz
Mana-8eadc834ed3e8439836f7dc87390a56a1164ec11.tar.bz2
Mana-8eadc834ed3e8439836f7dc87390a56a1164ec11.tar.xz
Mana-8eadc834ed3e8439836f7dc87390a56a1164ec11.zip
Simplify handling of compressed files
ResourceManager will now check for ".gz" and act appropriately (unless told not to). Compression handling functions are now in new utils/zlib files, along with a function to load a file from drive, uncompressing it if it ends in ".gz". Reviewed-by: Freeyorp
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9b38b496..6c470aef 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -402,6 +402,8 @@ SET(SRCS
utils/mkdir.h
utils/xml.cpp
utils/xml.h
+ utils/zlib.cpp
+ utils/zlib.h
animatedsprite.cpp
animatedsprite.h
animationparticle.cpp