summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-11 15:47:35 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-11 15:47:35 +0000
commit8da32105732949b4b0273c718d118bcfae70a1c9 (patch)
tree0a354974d48268cfaafcdb1e06b498fa26a59c1e /src/CMakeLists.txt
parentf9ce4e302cb3ed203d89a7a18e10b7ad4f11519c (diff)
downloadMana-8da32105732949b4b0273c718d118bcfae70a1c9.tar.gz
Mana-8da32105732949b4b0273c718d118bcfae70a1c9.tar.bz2
Mana-8da32105732949b4b0273c718d118bcfae70a1c9.tar.xz
Mana-8da32105732949b4b0273c718d118bcfae70a1c9.zip
Merged 0.0 changes from revision 2825 to 2898 to trunk.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4fd8d880..e0b93382 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -155,6 +155,8 @@ SET(SRCS
gui/vbox.h
gui/windowcontainer.cpp
gui/windowcontainer.h
+ gui/viewport.cpp
+ gui/viewport.h
gui/window.cpp
gui/window.h
gui/widgets/dropdown.cpp
@@ -216,17 +218,24 @@ SET(SRCS
resources/ambientoverlay.h
resources/buddylist.cpp
resources/buddylist.h
+ resources/equipmentdb.cpp
+ resources/equipmentdb.h
+ resources/equipmentinfo.h
resources/image.cpp
resources/image.h
resources/imagewriter.cpp
resources/imagewriter.h
resources/iteminfo.cpp
+ resources/itemdb.cpp
+ resources/itemdb.h
resources/iteminfo.h
- resources/itemmanager.cpp
- resources/itemmanager.h
resources/mapreader.cpp
resources/mapreader.h
resources/music.cpp
+ resources/monsterdb.h
+ resources/monsterdb.cpp
+ resources/monsterinfo.h
+ resources/monsterinfo.cpp
resources/music.h
resources/openglsdlimageloader.cpp
resources/openglsdlimageloader.h
@@ -239,9 +248,15 @@ SET(SRCS
resources/soundeffect.cpp
resources/soundeffect.h
resources/spriteset.cpp
+ resources/spritedef.h
+ resources/spritedef.cpp
resources/spriteset.h
utils/dtor.h
utils/tostring.h
+ utils/xml.cpp
+ utils/xml.h
+ action.cpp
+ action.h
animatedsprite.cpp
animatedsprite.h
animation.cpp