summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBertram <bertram@cegetel.net>2009-07-24 22:59:13 +0200
committerBertram <bertram@cegetel.net>2009-07-24 22:59:13 +0200
commit8195e73cb801d56240beb966554a864729d9f20c (patch)
treef2a00036d15eaf70cb9abe4930b4199b1e5eae05 /src/CMakeLists.txt
parentea6f492198a03cffc3be47df000fa16dfc3b262f (diff)
downloadMana-8195e73cb801d56240beb966554a864729d9f20c.tar.gz
Mana-8195e73cb801d56240beb966554a864729d9f20c.tar.bz2
Mana-8195e73cb801d56240beb966554a864729d9f20c.tar.xz
Mana-8195e73cb801d56240beb966554a864729d9f20c.zip
Made the wallpaper be rescaled when necessary under SDL and OpenGL.
The SDL methods to rescale the wallpaper has been optimized to permit rescaling at load time while OpenGL draws directly rescaled. Does someone know how to smooth the rescaled image under OpenGL?
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 15109185..43726f9d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -304,6 +304,8 @@ SET(SRCS
resources/resource.h
resources/resourcemanager.cpp
resources/resourcemanager.h
+ resources/sdlrescalefacility.h
+ resources/sdlrescalefacility.cpp
resources/soundeffect.h
resources/soundeffect.cpp
resources/spritedef.h