summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-05 16:21:56 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-05 16:21:56 +0000
commit1828eee6a6d91fd385ad1e69d93044516493aa91 (patch)
tree9e7e86955e2d79f4f21daacf009312efd90dc70e /configure.ac
parent52abf02fb5521a00e78903addda6f8a20896f18f (diff)
downloadMana-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.gz
Mana-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.bz2
Mana-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.xz
Mana-1828eee6a6d91fd385ad1e69d93044516493aa91.zip
Added support for internationalization. Tested by translating a few gui strings to french.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 21d9ef56..b6803c11 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,20 +1,15 @@
AC_PREREQ(2.59)
-AC_INIT([The Mana World], [0.1.0], [elvenprogrammer@gmail.com], [tmw])
+AC_INIT([The Mana World], [0.1.0], [themanaworld-devel@lists.sourceforge.net], [tmw])
AM_INIT_AUTOMAKE
AC_CONFIG_HEADERS([config.h:config.h.in])
AC_LANG_CPLUSPLUS
# Checks for programs.
AC_PROG_CXX
-AC_PROG_CC
AC_PROG_INSTALL
-AC_PROG_MAKE_SET
# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_CONST
AC_HEADER_TIME
-AC_C_VOLATILE
# Checks for library functions.
AC_FUNC_ERROR_AT_LINE
@@ -24,6 +19,9 @@ AC_FUNC_SELECT_ARGTYPES
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])
+# Checks for internationalization support
+AM_GNU_GETTEXT([external])
+
# Search for *-config
AC_PATH_PROG(SDL_CONFIG, sdl-config)
AC_PATH_PROG(PKG_CONFIG, pkg-config)
@@ -98,6 +96,7 @@ AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
if test "x$with_opengl" == "xno"; then
with_opengl=no
else
+ with_opengl=yes
AC_CHECK_LIB([GL], [glBegin], ,
AC_MSG_ERROR([ *** Unable to find OpenGL library]))
AC_CHECK_LIB([guichan_opengl], [gcnOpenGL], ,
@@ -117,6 +116,7 @@ data/graphics/tiles/Makefile
data/help/Makefile
data/icons/Makefile
docs/Makefile
+po/Makefile.in
])
AC_OUTPUT