summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-02-24 21:16:12 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-03-24 22:28:23 +0100
commita5690fa2a4cce2698225f1f558183f6fe306d860 (patch)
tree822d4e237412afd38008de04d9be11fd0718f101 /CMakeLists.txt
parent054246ebffcdd20da72a8e464b40eaf64d484743 (diff)
downloadMana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.gz
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.bz2
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.tar.xz
Mana-a5690fa2a4cce2698225f1f558183f6fe306d860.zip
Introduced compile-time option to disable use of C++0x
This is in order to still support older compilers, in particular GCC 4.2.1, so that Mana may be compiled for Maemo 5. Reviewed-by: Yohann Ferreira
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3710a027..2e06d02d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,7 @@ FIND_PACKAGE(Gettext)
OPTION(WITH_OPENGL "Enable OpenGL support" ON)
OPTION(ENABLE_NLS "Enable building of tranlations" ON)
OPTION(ENABLE_MANASERV "Enable Manaserv support" OFF)
+OPTION(ENABLE_CPP0X "Enable use of C++0x features" ON)
IF (WIN32)
SET(PKG_DATADIR ".")