summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-02-21 16:33:21 +0300
committerAndrei Karas <akaras@inbox.ru>2015-02-21 16:33:31 +0300
commit875a09d8a893fd17c43d85e9a318ff0d4d359e6f (patch)
treecc1f62f8b786c98f56d51b5c756e9e4ca125e4d0 /configure.ac
parent8e50387632bd4bbab6f1a85b94afa24340a3ce19 (diff)
downloadevol-hercules-875a09d8a893fd17c43d85e9a318ff0d4d359e6f.tar.gz
evol-hercules-875a09d8a893fd17c43d85e9a318ff0d4d359e6f.tar.bz2
evol-hercules-875a09d8a893fd17c43d85e9a318ff0d4d359e6f.tar.xz
evol-hercules-875a09d8a893fd17c43d85e9a318ff0d4d359e6f.zip
Add gprof build flag.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f922d99..1f8435b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,26 @@ AC_ARG_ENABLE(
)
AM_CONDITIONAL(ENABLE_STATIC, test x$enable_static = xyes)
+AC_ARG_ENABLE(
+ [gprof],
+ AC_HELP_STRING(
+ [--enable-gprof],
+ [
+ Enables or Disables Gprof (disabled by default)
+ ]
+ ),
+ [
+ enable_gprof="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-gprof=$disableval... stopping]]);;
+ esac
+ ],
+ [enable_gprof="no"]
+)
+AM_CONDITIONAL(ENABLE_GPROF, test x$enable_gprof = xyes)
+
AC_CHECK_FUNC([strnlen],[CFLAGS="$CFLAGS -DHAVE_STRNLEN"])
AC_CHECK_FUNC([setrlimit],[CLAGS="$CFLAGS -DHAVE_SETRLIMIT"])