summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2020-03-30 06:27:13 +0300
committerAndrei Karas <akaras@inbox.ru>2020-03-30 06:35:11 +0300
commitc0e51f774c8c3c0ee763e166fd4534624966edcf (patch)
tree53b2dc50319249b7f27a7f8275177d198516e1a9 /configure.ac
parent7bd523fca9a4e86772e2c8b1a84377f64ea2d968 (diff)
downloadhercules-c0e51f774c8c3c0ee763e166fd4534624966edcf.tar.gz
hercules-c0e51f774c8c3c0ee763e166fd4534624966edcf.tar.bz2
hercules-c0e51f774c8c3c0ee763e166fd4534624966edcf.tar.xz
hercules-c0e51f774c8c3c0ee763e166fd4534624966edcf.zip
Enable libbacktrace by default only on Linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e13fc4b6c..df3da8266 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,8 +38,11 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
[AC_GNU_SOURCE]
)
+AC_MSG_CHECKING([host OS])
+host_os="`uname`"
+AC_MSG_RESULT([$host_os])
+
# Root-check
-host_is="`uname`"
case $host_os in
CYGWIN*)
;;
@@ -330,7 +333,16 @@ AC_ARG_ENABLE(
*) AC_MSG_ERROR([[invalid argument --enable-libbacktrace=$enableval... stopping]]);;
esac
],
- [enable_libbacktrace="no"]
+ [
+ case $host_os in
+ Linux* )
+ enable_libbacktrace="yes"
+ ;;
+ *)
+ enable_libbacktrace="no"
+ ;;
+ esac
+ ]
)
#
@@ -1698,9 +1710,6 @@ AC_CHECK_FLAG(-fno-var-tracking)
#
# Host specific stuff
#
-AC_MSG_CHECKING([host OS])
-host_os="`uname`"
-AC_MSG_RESULT([$host_os])
fd_setsize=""
DLLEXT=".so"
case $host_os in