summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2014-11-13 17:36:57 +0300
committerAndrei Karas <akaras@inbox.ru>2014-11-13 17:36:57 +0300
commitc55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51 (patch)
tree81481e7e4871d65ce22d1945efe22386689e6423 /src/Makefile.am
parent0e184a35c76ac02d58467da556e665cd45083557 (diff)
downloadevol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.gz
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.bz2
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.tar.xz
evol-hercules-c55ed43cd52dcd32fe1c3cd5a9d41f856dd4fe51.zip
Add configure option --enable-sanitize.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index be513e7..a00b5b9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,9 +21,13 @@ MAP_SRC = map/dummy.c \
map/session.h \
map/sessionext.h
-SHARED_CFLAGS = -pipe -ffast-math -Wall -Wextra -Wno-sign-compare -fsanitize=address
+SHARED_CFLAGS = -pipe -ffast-math -Wall -Wextra -Wno-sign-compare
+SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined
-SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined -lasan
+if ENABLE_SANITIZE
+SHARED_CFLAGS += -fsanitize=address
+SHARED_LDFLAGS = -lasan
+endif
if ENABLE_STATIC
SHARED_CFLAGS += "-static-libgcc"