summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
committerRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
commit5d557c39a307b5a727919c527f14c535d5922df0 (patch)
tree28ea6254d9d8edb45b38ce4f48e8203b364c37b9 /Makefile.am
parentba1adfb47b04e6f551ea3d221b532b201bbaaac3 (diff)
downloadclientdata-5d557c39a307b5a727919c527f14c535d5922df0.tar.gz
clientdata-5d557c39a307b5a727919c527f14c535d5922df0.tar.bz2
clientdata-5d557c39a307b5a727919c527f14c535d5922df0.tar.xz
clientdata-5d557c39a307b5a727919c527f14c535d5922df0.zip
- Added installation of game data, install required on *nix systems
- Updated desktop file to work better - Install the desktop file to the standard location - Install the icon as tmw.png in the standard pixmaps data dir
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 10 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index 252e8b5a..039fe68c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,29 +1,10 @@
-EXTRA_DIST = maps/new_1-1.tmx.gz \
- maps/new_3-1.tmx.gz \
- graphics/gui/bg_quad_dis.png \
- graphics/gui/button.png \
- graphics/gui/button_disabled.png \
- graphics/gui/buttonhi.png \
- graphics/gui/buttonpress.png \
- graphics/gui/checkbox.png \
- graphics/gui/fixedfont.png \
- graphics/gui/mouse.png \
- graphics/gui/radioin.png \
- graphics/gui/radioout.png \
- graphics/gui/slider.png \
- graphics/gui/textbox.png \
- graphics/gui/vscroll_blue.png \
- graphics/gui/vscroll_grey.png \
- graphics/gui/vscroll_red.png \
- graphics/tiles/desert1.png \
- graphics/tiles/desert2.png \
- graphics/tiles/collision.png \
- graphics/sprites/emotions.png \
- graphics/sprites/items.png \
- graphics/sprites/monsters.png \
- graphics/sprites/npcs.png \
- graphics/sprites/player_male_base.png \
- graphics/sprites/player_male_hair.png \
- graphics/sprites/weapons.png \
- graphics/images/login_wallpaper.png \
- sfx/bow_shoot_1.ogg
+
+SUBDIRS = graphics icons maps sfx
+
+tmwdatadir = $(pkgdatadir)/data
+
+tmwdata_DATA = \
+ items.xml
+
+EXTRA_DIST = \
+ $(tmwdata_DATA) \ No newline at end of file