summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5bf511b92..af00bbdf8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -132,6 +132,18 @@ manaplus_SOURCES =
dyecmd_SOURCES =
endif
+if ENABLE_STLDEBUG
+dyecmd_CXXFLAGS += -DENABLE_STL_DEBUG
+manaplus_CXXFLAGS += -DENABLE_STL_DEBUG -DDEBUG_DUMP_LEAKS
+
+manaplus_SOURCES += debug/mse/msemsevector.h \
+ debug/mse/msemstdvector.h \
+ debug/mse/mseprimitives.h
+dyecmd_SOURCES += debug/mse/msemsevector.h \
+ debug/mse/msemstdvector.h \
+ debug/mse/mseprimitives.h
+endif
+
if MINGW
manaplus_SOURCES += manaplus.rc
dyecmd_SOURCES += manaplus.rc