summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-02-27 00:37:57 +0300
committerAndrei Karas <akaras@inbox.ru>2015-02-27 01:51:18 +0300
commitccd272519ec38b15fa5ec24fe4c6daa6eb45e3da (patch)
tree863537991d40a9665191ad9cbf69df81112d2b0a /src/Makefile.am
parent5b9f5605671f09849e1bc59fa862e2e7e9b9e0a8 (diff)
downloadplus-ccd272519ec38b15fa5ec24fe4c6daa6eb45e3da.tar.gz
plus-ccd272519ec38b15fa5ec24fe4c6daa6eb45e3da.tar.bz2
plus-ccd272519ec38b15fa5ec24fe4c6daa6eb45e3da.tar.xz
plus-ccd272519ec38b15fa5ec24fe4c6daa6eb45e3da.zip
Fix compilation for eathena only.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 80d4128c5..289aa0116 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1324,6 +1324,15 @@ manaplus_SOURCES += \
endif
if ENABLE_EATHENA
+if ENABLE_TMWA
+manaplus_SOURCES += net/tmwa/auctionhandler.cpp \
+ net/tmwa/auctionhandler.h \
+ net/tmwa/bankhandler.cpp \
+ net/tmwa/bankhandler.h \
+ net/tmwa/buyingstorehandler.cpp \
+ net/tmwa/buyingstorehandler.h
+endif
+
manaplus_CXXFLAGS += -DEATHENA_SUPPORT
manaplus_SOURCES += gui/windows/bankwindow.cpp \
gui/windows/bankwindow.h \
@@ -1348,12 +1357,6 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
net/auctionhandler.h \
net/bankhandler.h \
net/buyingstorehandler.h \
- net/tmwa/auctionhandler.cpp \
- net/tmwa/auctionhandler.h \
- net/tmwa/bankhandler.cpp \
- net/tmwa/bankhandler.h \
- net/tmwa/buyingstorehandler.cpp \
- net/tmwa/buyingstorehandler.h \
net/eathena/adminhandler.cpp \
net/eathena/adminhandler.h \
net/eathena/auctionhandler.cpp \