summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFedja Beader <fedja@protonmail.ch>2024-08-22 10:19:27 +0000
committerFedja Beader <fedja@protonmail.ch>2024-08-22 10:19:27 +0000
commitf3457a5e0f5b803ff476172f23cff9b4fdb31cbe (patch)
tree0f4d2e54e9d54a00bee051a8fa934dfdcbf84f88 /configure.ac
parent2f932e192e18a5efcd12b600337726b534f759a3 (diff)
downloadplus-f3457a5e0f5b803ff476172f23cff9b4fdb31cbe.tar.gz
plus-f3457a5e0f5b803ff476172f23cff9b4fdb31cbe.tar.bz2
plus-f3457a5e0f5b803ff476172f23cff9b4fdb31cbe.tar.xz
plus-f3457a5e0f5b803ff476172f23cff9b4fdb31cbe.zip
POSIX test does not support ==
Reported by Skyflare **** mana/plus!97
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac84
1 files changed, 42 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index f4e2e1599..11a42ce78 100755
--- a/configure.ac
+++ b/configure.ac
@@ -176,10 +176,10 @@ esac],[androidbuild_enabled=false])
# Enable for dyecmd
AC_ARG_WITH(dyecmd,[ --with-dyecmd build dyecmd tool ] )
-if test "x$with_dyecmd" == "xno"; then
+if test "x$with_dyecmd" = "xno"; then
with_dyecmd=no
else
- if test "x$androidbuild_enabled" == "xfalse"; then
+ if test "x$androidbuild_enabled" = "xfalse"; then
with_dyecmd=yes
else
with_dyecmd=no
@@ -190,7 +190,7 @@ AM_CONDITIONAL(ENABLE_DYECMD, test x$with_dyecmd = xyes)
# Option to enable ManaPlus game
AC_ARG_WITH(manaplusgame,[ --without-manaplusgame don't build ManaPlus game ] )
-if test "x$with_manaplusgame" == "xno"; then
+if test "x$with_manaplusgame" = "xno"; then
with_manaplusgame=no
else
with_manaplusgame=yes
@@ -220,8 +220,8 @@ AC_HEADER_TIME
AC_FUNC_ERROR_AT_LINE
# disabled because look like build issue with some libc versions with asan
-#if test "x$androidbuild_enabled" == "xfalse"; then
-# if test "x$naclbuild_enabled" == "xfalse"; then
+#if test "x$androidbuild_enabled" = "xfalse"; then
+# if test "x$naclbuild_enabled" = "xfalse"; then
# AC_FUNC_MALLOC
# AC_FUNC_REALLOC
# fi
@@ -284,13 +284,13 @@ AC_DEFUN([AC_CHECK_SDL],
[
# Enable sdl2
AC_ARG_WITH(sdl2,[ --with-sdl2 enable SDL 2 support] )
-if test "x$with_sdl2" == "xyes"; then
+if test "x$with_sdl2" = "xyes"; then
AC_PATH_PROG(SDL_CONFIG, sdl2-config)
if test -n "$SDL_CONFIG"; then
LIBS="$LIBS `$SDL_CONFIG --libs`"
CPPFLAGS="$CPPFLAGS `$SDL_CONFIG --cflags`"
fi
- if test "x$with_internalsdlgfx" == "xno"; then
+ if test "x$with_internalsdlgfx" = "xno"; then
LIBS="$LIBS `$PKG_CONFIG --libs SDL2_gfx`"
CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags SDL2_gfx`"
fi
@@ -303,7 +303,7 @@ if test "x$with_sdl2" == "xyes"; then
LIBS="$LIBS `$PKG_CONFIG --libs SDL2_ttf`"
CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags SDL2_ttf`"
- if test "$skip_check_lib" == "no"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([SDL2], [SDL_Init], ,
AC_MSG_ERROR([ *** Unable to find SDL2 library (http://www.libsdl.org/)]))
@@ -337,8 +337,8 @@ else
LIBS="$LIBS `$PKG_CONFIG --libs SDL_ttf`"
CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags SDL_ttf`"
- if test "x$naclbuild_enabled" == "xfalse"; then
- if test "$skip_check_lib" == "no"; then
+ if test "x$naclbuild_enabled" = "xfalse"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([SDL], [SDL_Init], ,
AC_MSG_ERROR([ *** Unable to find SDL library (http://www.libsdl.org/)]))
@@ -369,10 +369,10 @@ AC_CHECK_GLXEXT(have_glext)
AM_CONDITIONAL(HAVE_GLEXT, test x$have_glext = xyes)
# Option to enable internal sdl-gfx for SDL2 (for now it enabled by default)
-if test "x$with_internalsdlgfx" == "xno"; then
+if test "x$with_internalsdlgfx" = "xno"; then
with_internalsdlgfx=no
- if test "$skip_check_lib" == "no"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB(SDL2_gfx, rotozoomSurfaceXY, ,
AC_MSG_ERROR([ *** Unable to find SDL2_gfx library (http://www.ferzkopp.net/joomla/software-mainmenu-14/4-ferzkopps-linux-software/19-sdlgfx)]))
fi
@@ -387,17 +387,17 @@ AC_CHECK_HEADERS([SDL.h], ,
AC_MSG_ERROR([ *** SDL library found but cannot find headers (http://www.libsdl.org/)]))
])
-if test "x$naclbuild_enabled" == "xfalse"; then
+if test "x$naclbuild_enabled" = "xfalse"; then
AC_CHECK_SDL()
fi
# Checks for libraries
AC_ARG_WITH(pthread,[ --without-pthread don't check for pthread ] )
-if test "x$with_pthread" == "xno"; then
+if test "x$with_pthread" = "xno"; then
without_pthread=yes
else
- if test "x$androidbuild_enabled" == "xfalse"; then
- if test "$skip_check_lib" == "no"; then
+ if test "x$androidbuild_enabled" = "xfalse"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([pthread], [pthread_create], ,
AC_MSG_ERROR([ *** Unable to find pthread library]))
fi
@@ -405,7 +405,7 @@ else
withoud_pthread=no
fi
-if test "$skip_check_lib" == "no"; then
+if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([z], [inflate], ,
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
fi
@@ -414,7 +414,7 @@ if test -n "$CURL_CONFIG"; then
LIBS="$LIBS `$CURL_CONFIG --libs`"
CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
fi
-if test "$skip_check_lib" == "no"; then
+if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([curl], [curl_global_init], ,
AC_MSG_ERROR([ *** Unable to find CURL library (http://curl.haxx.se/)]))
fi
@@ -455,12 +455,12 @@ case $xmllib in
;;
esac
-if test "$xmllib" == "libxml"; then
+if test "$xmllib" = "libxml"; then
if test -n "$PKG_CONFIG"; then
LIBS="$LIBS `$PKG_CONFIG --libs libxml-2.0`"
CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags libxml-2.0`"
fi
- if test "$skip_check_lib" == "no"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([xml2], [xmlInitParser], ,
AC_MSG_ERROR([ *** Unable to find libxml2 library (http://xmlsoft.org/)]))
fi
@@ -474,7 +474,7 @@ if test "$xmllib" == "libxml"; then
icu_bug=yes
$as_unset ac_cv_header_libxml_xmlreader_h
)
- if test "$icu_bug" == "yes"; then
+ if test "$icu_bug" = "yes"; then
AC_CHECK_HEADERS(
[libxml/xmlreader.h],
,
@@ -483,8 +483,8 @@ if test "$xmllib" == "libxml"; then
fi
fi
-if test "$xmllib" == "pugixml"; then
- if test "$skip_check_lib" == "no"; then
+if test "$xmllib" = "pugixml"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([pugixml], [main], ,
AC_MSG_ERROR([ *** Unable to find pugixml library (http://pugixml.org/)]))
fi
@@ -494,8 +494,8 @@ fi
# hack for support unversioned api change in tinyxml2 (master branch)
tinyxml2_old=yes
-if test "$xmllib" == "tinyxml2"; then
- if test "$skip_check_lib" == "no"; then
+if test "$xmllib" = "tinyxml2"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([tinyxml2], [main], ,
AC_MSG_ERROR([ *** Unable to find tinyxml2 library (http://grinninglizard.com/tinyxml2/)]))
AC_MSG_CHECKING([whether tinyxml supports old error api])
@@ -558,7 +558,7 @@ fi
AM_CONDITIONAL(USE_TINYXML_OLD, test x$tinyxml2_old = xyes)
-if test "$skip_check_lib" == "no"; then
+if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB(png, png_write_info, ,
AC_MSG_ERROR([ *** Unable to find png library]))
fi
@@ -604,7 +604,7 @@ esac],[applebuild_enabled=false])
# Option to enable gcov
AC_ARG_WITH(gcov,[ --with-gcov use gcov ] )
-if test "x$with_gcov" == "xyes"; then
+if test "x$with_gcov" = "xyes"; then
with_gcov=yes
CPPFLAGS="$CPPFLAGS -coverage"
LDFLAGS="$LDFLAGS -coverage"
@@ -615,14 +615,14 @@ AM_CONDITIONAL(USE_GCOV, test x$with_gcov = xyes)
# Option to enable OpenGL
AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
-if test "x$with_opengl" == "xno"; then
+if test "x$with_opengl" = "xno"; then
with_opengl=no
else
with_opengl=yes
- if test "x$applebuild_enabled" == "xfalse"; then
- if test "x$androidbuild_enabled" == "xfalse"; then
- if test "x$naclbuild_enabled" == "xfalse"; then
- if test "$skip_check_lib" == "no"; then
+ if test "x$applebuild_enabled" = "xfalse"; then
+ if test "x$androidbuild_enabled" = "xfalse"; then
+ if test "x$naclbuild_enabled" = "xfalse"; then
+ if test "$skip_check_lib" = "no"; then
AC_CHECK_LIB([GL], [glBegin], ,
AC_MSG_ERROR([ *** Unable to find OpenGL library]))
fi
@@ -642,10 +642,10 @@ AM_CONDITIONAL(USE_OPENGL, test x$with_opengl = xyes)
# Option to enable mumble support
AC_ARG_WITH(mumble,[ --without-mumble don't use mumble integration ] )
-if test "x$with_mumble" == "xno"; then
+if test "x$with_mumble" = "xno"; then
with_mumble=no
else
- if test "x$androidbuild_enabled" == "xfalse"; then
+ if test "x$androidbuild_enabled" = "xfalse"; then
with_mumble=yes
else
with_mumble=no
@@ -655,13 +655,13 @@ AM_CONDITIONAL(USE_MUMBLE, test x$with_mumble = xyes)
AC_ARG_WITH(librt,[ --without-librt don't link to librt ] )
-if test "x$with_librt" == "xno"; then
+if test "x$with_librt" = "xno"; then
without_librt=yes
else
- if test "x$applebuild_enabled" == "xfalse"; then
- if test "x$androidbuild_enabled" == "xfalse"; then
+ if test "x$applebuild_enabled" = "xfalse"; then
+ if test "x$androidbuild_enabled" = "xfalse"; then
AC_CHECK_LD_FLAG(-lrt, use_librt)
- if test "x$use_librt" == "xyes"; then
+ if test "x$use_librt" = "xyes"; then
AC_CHECK_LIB(rt, shm_open, ,
AC_MSG_ERROR([ *** Unable to find librt library]))
fi
@@ -864,7 +864,7 @@ esac],[customnls_enabled=false])
AM_CONDITIONAL(ENABLE_CUSTOMNLS, test x$customnls_enabled = xtrue)
-if test "x$naclbuild_enabled" == "xtrue"; then
+if test "x$naclbuild_enabled" = "xtrue"; then
AC_CHECK_SDL()
fi
@@ -940,13 +940,13 @@ AC_CONFIG_FILES([data/tmw/tmw], [chmod +x data/tmw/tmw])
AC_OUTPUT
echo
-if test "$with_manaplusgame" == "yes"; then
+if test "$with_manaplusgame" = "yes"; then
echo "Enabled building manaplus game."
fi
-if test "$with_dyecmd" == "yes"; then
+if test "$with_dyecmd" = "yes"; then
echo "Enabled building dyecmd tool."
fi
-if test "$unittests_enabled" == true; then
+if test "$unittests_enabled" = true; then
echo "Enabled building unit tests."
fi