summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-12-09 23:58:03 +0300
committerAndrei Karas <akaras@inbox.ru>2015-12-10 00:14:40 +0300
commit7d3ef8d375defc9fb7efb4e48b72a6f4f9b98c16 (patch)
treee47def44f377e32766e30949449b9a1ca9aea34d /configure.ac
parent16450153ba29080df48654e7a13aa017f982c8c9 (diff)
downloadplus-7d3ef8d375defc9fb7efb4e48b72a6f4f9b98c16.tar.gz
plus-7d3ef8d375defc9fb7efb4e48b72a6f4f9b98c16.tar.bz2
plus-7d3ef8d375defc9fb7efb4e48b72a6f4f9b98c16.tar.xz
plus-7d3ef8d375defc9fb7efb4e48b72a6f4f9b98c16.zip
Disable malloc and realloc in configure.
Look like it create issues in new libc.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8260b0588..115421877 100755
--- a/configure.ac
+++ b/configure.ac
@@ -52,12 +52,13 @@ AC_HEADER_TIME
# Checks for library functions.
AC_FUNC_ERROR_AT_LINE
-if test "x$androidbuild_enabled" == "xfalse"; then
- if test "x$naclbuild_enabled" == "xfalse"; then
- AC_FUNC_MALLOC
- AC_FUNC_REALLOC
- fi
-fi
+# disabled because look like build issue with some libc versions with asan
+#if test "x$androidbuild_enabled" == "xfalse"; then
+# if test "x$naclbuild_enabled" == "xfalse"; then
+# AC_FUNC_MALLOC
+# AC_FUNC_REALLOC
+# fi
+#fi
AC_C_INLINE
AC_FUNC_SELECT_ARGTYPES