summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-04-25 16:54:44 +0300
committerAndrei Karas <akaras@inbox.ru>2017-04-25 16:54:44 +0300
commit51b81830c032fe255254a269b85679a89aa3728d (patch)
tree00f00059b167a621eb4933b6b7ffa66d31c9a715 /configure.ac
parentb873a942a8e78d42d159aa1e307b7c8155d6e755 (diff)
downloadplus-51b81830c032fe255254a269b85679a89aa3728d.tar.gz
plus-51b81830c032fe255254a269b85679a89aa3728d.tar.bz2
plus-51b81830c032fe255254a269b85679a89aa3728d.tar.xz
plus-51b81830c032fe255254a269b85679a89aa3728d.zip
Add configure option --enable-openglerrors for report OpenGL errors on legacy drivers.
This option slow down execution, but can be usefull for debugging.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec2230a98..05fed8a7e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,19 @@ esac],[glibcdebug_enabled=false])
AM_CONDITIONAL(ENABLE_GLIBCDEBUG, test x$glibcdebug_enabled = xtrue)
+# Enable OpenGL error reporting
+AC_ARG_ENABLE(openglerrors,
+[ --enable-openglerrors Enable OpenGL errors reporting],
+[case "${enableval}" in
+ yes) openglerrors_enabled=true
+ ;;
+ no) openglerrors_enabled=false
+ ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-openglerrors) ;;
+esac],[openglerrors_enabled=false])
+
+AM_CONDITIONAL(ENABLE_OPENGLERRORS, test x$openglerrors_enabled = xtrue)
+
# Checks for android.
AC_ARG_ENABLE(androidbuild,
[ --enable-androidbuild Turn on android building],