summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Sagunov <danilka.pro@gmail.com>2012-10-15 18:25:40 +0400
committerDan Sagunov <danilka.pro@gmail.com>2012-10-15 18:25:40 +0400
commit37e870866404d8065d732d785e3086699d6834fc (patch)
tree1afb4a49599fdb715770cfb39281dfb8efe609a9 /configure.ac
parentcd93bdb016c135437826b694f96a6c2408aaba19 (diff)
downloadplus-37e870866404d8065d732d785e3086699d6834fc.tar.gz
plus-37e870866404d8065d732d785e3086699d6834fc.tar.bz2
plus-37e870866404d8065d732d785e3086699d6834fc.tar.xz
plus-37e870866404d8065d732d785e3086699d6834fc.zip
Added androidbuild checking in configure
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 46d88b797..56d28c307 100755
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,18 @@ AM_INIT_AUTOMAKE([1.9])
AC_CONFIG_HEADERS([config.h:config.h.in])
AC_LANG_CPLUSPLUS
+# Checks for android.
+# Enable mac build
+AC_ARG_ENABLE(androidbuild,
+[ --enable-androidbuild Turn on android building],
+[case "${enableval}" in
+ yes) androidbuild_enabled=true
+ ;;
+ no) androidbuild_enabled=false
+ ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-androidbuild) ;;
+esac],[androidbuild_enabled=false])
+
# Checks for programs.
AC_PROG_CXX
AM_PROG_CC_C_O
@@ -14,8 +26,12 @@ AC_HEADER_TIME
# Checks for library functions.
AC_FUNC_ERROR_AT_LINE
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
+
+if test "x$androidbuild_enabled" == "xfalse"; then
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+fi
+
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([atexit floor getcwd gethostbyname memset mkdir select socket])